[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

building tlaplus from source fails

I have never used maven before, I want to use the latest tlaplus from github so I clone the repo, here's a git log:
commit 4605eac8e720ae54cba08522c1bc6890e74d2998 (HEAD -> master, origin/master, origin/HEAD)
Author: Markus Alexander Kuppe <tlapl...@xxxxxxxxxxx>
Date:   Sun Nov 11 16:50:47 2018 -0800

    Prevent div-by-zero in calculating collision probability when zero
    states are generated.

I install maven and I am using openjdk

I run maven package; that fails after about 2 hours. I run maven install that fails with this error:

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] TLA+ Tools and TLA Toolbox 0.0.1-SNAPSHOT .......... SUCCESS [  0.247 s]
[INFO] org.lamport.tlatools 1.0.0-SNAPSHOT ................ SUCCESS [18:49 min]
[INFO] org.lamport.tlatools.api 1.0.0-SNAPSHOT ............ SUCCESS [  0.699 s]
[INFO] org.lamport.tlatools.impl.distributed 1.0.0-SNAPSHOT SUCCESS [  0.771 s]
[INFO] org.lamport.tlatools.consumer.distributed 1.0.0-SNAPSHOT SUCCESS [  0.806 s]
[INFO] org.lamport.tla.toolbox.product.standalone 1.0.0-SNAPSHOT SUCCESS [  0.982 s]
[INFO] org.lamport.tla.toolbox 1.0.0-SNAPSHOT ............. SUCCESS [  1.703 s]
[INFO] org.lamport.tla.toolbox.tool.tlc 1.0.0-SNAPSHOT .... SUCCESS [  1.178 s]
[INFO] org.lamport.tla.toolbox.jclouds 1.0.0-SNAPSHOT ..... SUCCESS [  1.460 s]
[INFO] org.lamport.tla.toolbox.jnlp 1.0.0-SNAPSHOT ........ SUCCESS [  4.572 s]
[INFO] org.lamport.tla.toolbox.doc 1.5.4-SNAPSHOT ......... SUCCESS [  1.538 s]
[INFO] org.lamport.tla.toolbox.editor.basic 1.0.0-SNAPSHOT  SUCCESS [  1.586 s]
[INFO] org.lamport.tla.toolbox.tool.prover 1.0.0-SNAPSHOT . SUCCESS [  1.050 s]
[INFO] org.lamport.tla.toolbox.tool.tla2tex 1.0.0-SNAPSHOT  SUCCESS [  0.831 s]
[INFO] org.lamport.tla.toolbox.tool.tlc.ui 1.0.0-SNAPSHOT . SUCCESS [  2.064 s]
[INFO] org.lamport.tla.toolbox.test 1.0.0-SNAPSHOT ........ SUCCESS [54:05 min]
[INFO] org.lamport.tla.toolbox.tool.tlc.test 1.0.0-SNAPSHOT SUCCESS [  9.286 s]
[INFO] org.lamport.tla.toolbox.tool.tlc.ui.test 1.0.0-SNAPSHOT SUCCESS [ 10.388 s]
[INFO] org.lamport.tla.toolbox.feature.branding 1.0.0-SNAPSHOT SUCCESS [  1.169 s]
[INFO] org.lamport.tla.toolbox.feature.base 1.0.0-SNAPSHOT  SUCCESS [  0.669 s]
[INFO] org.lamport.tla.toolbox.feature.editor 1.0.0-SNAPSHOT SUCCESS [  0.620 s]
[INFO] org.lamport.tla.toolbox.feature.help 1.0.0-SNAPSHOT  SUCCESS [  0.596 s]
[INFO] org.lamport.tla.toolbox.feature.jclouds 1.0.0-SNAPSHOT SUCCESS [  0.647 s]
[INFO] org.lamport.tla.toolbox.feature.jnlp 1.0.0-SNAPSHOT  SUCCESS [  0.593 s]
[INFO] org.lamport.tla.toolbox.feature.prover 1.0.0-SNAPSHOT SUCCESS [  0.610 s]
[INFO] org.lamport.tla.toolbox.feature.tlc 1.0.0-SNAPSHOT . SUCCESS [  0.640 s]
[INFO] org.lamport.tla.toolbox.feature.tla2tex 1.0.0-SNAPSHOT SUCCESS [  0.576 s]
[INFO] org.lamport.tlatools.feature 1.0.0-SNAPSHOT ........ SUCCESS [  0.627 s]
[INFO] org.lamport.tla.toolbox.feature.standalone 1.0.0-SNAPSHOT SUCCESS [  1.514 s]
[INFO] org.lamport.tla.toolbox.uitest 1.0.0-SNAPSHOT ...... SUCCESS [ 22.372 s]
[INFO] org.lamport.tla.toolbox.tool.tla2tex.uitest 1.0.0-SNAPSHOT FAILURE [32:15 min]
[INFO] org.lamport.tla.toolbox.tool.tlc.ui.uitest 1.0.0-SNAPSHOT SKIPPED
[INFO] org.lamport.tla.toolbox.feature.uitest 1.0.0-SNAPSHOT SKIPPED
[INFO] org.lamport.tla.toolbox.p2repository 1.0.0-SNAPSHOT  SKIPPED
[INFO] org.lamport.tla.toolbox.product.product 1.4.0-SNAPSHOT SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:47 h
[INFO] Finished at: 2018-11-16T01:39:35-05:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.eclipse.tycho:tycho-surefire-plugin:1.2.0:test (default-test) on project org.lamport.tla.toolbox.tool.tla2tex.uitest: Failed to resolve framework extension p2.osgi.bundle:org.eclipse.equinox.weaving.hook:jar: Missing:
[ERROR] ----------
[ERROR] 1) p2.osgi.bundle:org.eclipse.equinox.weaving.hook:jar:1.2.0.v20160929-1449
[ERROR]   Try downloading the file manually from the project website.
[ERROR]   Then, install it using the command: 
[ERROR]       mvn install:install-file -DgroupId=p2.osgi.bundle -DartifactId=org.eclipse.equinox.weaving.hook -Dversion=1.2.0.v20160929-1449 -Dpackaging=jar -Dfile=/path/to/file
[ERROR]   Alternatively, if you host your own repository you can deploy the file there: 
[ERROR]       mvn deploy:deploy-file -DgroupId=p2.osgi.bundle -DartifactId=org.eclipse.equinox.weaving.hook -Dversion=1.2.0.v20160929-1449 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
[ERROR] ----------
[ERROR] 1 required artifact is missing.
[ERROR] for artifact: 
[ERROR]   p2.osgi.bundle:org.eclipse.equinox.weaving.hook:jar:1.2.0.v20160929-1449
[ERROR] from the specified remote repositories:
[ERROR]   central (https://repo.maven.apache.org/maven2, releases=true, snapshots=false)
[ERROR] -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :org.lamport.tla.toolbox.tool.tla2tex.uitest

I would like to manually build tlaplus to follow github head.

I should be able to do mvn clean install and get tlaplus.

How can I build manually build this project?