[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlaplus] Cannot open toolbox after update

Following up:

It turned out that upgrading the toolbox from 1.5.3 to 1.5.6 directly does not work. You have to upgrade sequentially--so 1.5.3 to 1.5.4, then 1.5.4 to 1.5.5, then finally 1.5.5 to 1.5.6. Guess that's what I get for not upgrading immediately :)

So, for the next person stumbling on this and realizing they tried to upgrade non-sequentially, remove and reinstall the toolbox, and you should be good to go.


On Monday, March 12, 2018 at 12:00:32 PM UTC-5, Laura Santamaria wrote:
Ah, interesting. I'm holding off for a few days on trying that just to see if anyone wants me to dump any more information on what happened, but I'll definitely keep this in mind for installing when I do a fresh reinstall. Thanks!


On Friday, March 9, 2018 at 11:22:53 PM UTC-6, Steve Glaser wrote:
I had a similar problem, also on High Sierra.

Reinstalling the toolbox fixed that problem but created another one.

MacOS complained that the newly installed toolbox app was damaged and offered to move it to the trash.

Fix for that was as follows:

1.  Make sure you set the “Allow apps downloaded from App Store and identified developers” option (System Preferences -> Security & Privacy -> General).

2. Temporarily disable system policy security

  sudo spctl —master-disable

3. Run the toolbox, answer the “yes I really want to run this” prompt. I exited the toolbox but I don’t think this was required for things to work.

4. Re-enable system policy security

  sudo spctl —master-enable

5. You should be good to go (at least till the next toolbox update)

Steve Glaser

On Mar 9, 2018, 8:57 AM -0800, Laura Santamaria <nimb...@xxxxxxxxx>, wrote:
Hi folks,

I updated the toolbox using the built-in updater today, and I now cannot open the toolbox at all. When I try, I get a popup that says:
An error has occurred.
See the log file

I cannot find any logs (I do not have a $HOME/.tlaplus directory at all) as noted on https://tla.msr-inria.inria.fr/tlatoolbox/doc/trouble/trouble.html, and I cannot find a .tlaplus directory anywhere on my machine. I'd love to provide a log if I could, but I don't know where else to look.

I look to be getting the same issue as noted here: https://groups.google.com/d/msg/tlaplus/kmyOFXfpDic/O50H_ud8AQAJ

I can't tell what version of the toolbox I'm running because I didn't note down the update version before running the update. I dumped the information from the Info.plist file below in case that's useful.

System info:

MacOSX 10.13.3 (High Sierra)

Eclipse is not installed as an application (i.e., it does not appear in my Launchpad, and it is not listed as an installed application in the Applications directory).

$ /usr/libexec/java_home -V
Matching Java Virtual Machines (1):
1.8.0_121, x86_64: "Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_121.jdk/Contents/Home


$ cat Info.plist
<?xml version="1.0" encoding="UTF-8" standalone="no"?
<plist version="1.0"

<string>Eclipse 4.7 for Mac OS X, Copyright IBM Corp. and others 2002, 2016. All rights reserved.</string




If I run it by drilling down into the MacOS directory in the Application Directory > TLA+ Toolbox, I can kinda see a trace, but I can't get more information than this as the terminal window closes if I click OK on the dialog box (the GUI):

java.lang.IllegalStateException: Could not create a builder for the system bundle.
at org.eclipse.osgi.storage.Storage.checkSystemBundle(Storage.java:290)
at org.eclipse.osgi.storage.Storage.createStorage(Storage.java:90)
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:68)
at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:303)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:239)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
Caused by: org.osgi.framework.BundleException: A bundle is already installed with the name "org.eclipse.osgi" and version "3.12.0.v20170512-1932"
at org.eclipse.osgi.container.ModuleContainer.update(ModuleContainer.java:341)
at org.eclipse.osgi.storage.Storage.checkSystemBundle(Storage.java:281)
... 12 more

I will probably just remove and reinstall, but I thought I'd check here first in case folks want to drill down on the problem if they're seeing it elsewhere.



You received this message because you are subscribed to the Google Groups "tlaplus" group.
To unsubscribe from this group and stop receiving emails from it, send an email to tlaplu...@xxxxxxxxxxxxxxxx.
To post to this group, send email to tla...@xxxxxxxxxxxxxxxx.
Visit this group at https://groups.google.com/group/tlaplus.
For more options, visit https://groups.google.com/d/optout.