[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlaplus] Failed to run TLA+ Toolbox 1.5.3 on Mac OS El Capitan


Thanks for the help !

I tried the nightly build mentioned in the "Trouble Running Toolbox on macOS Sierra" thread and that threw a better error message about the Java installation. Apparently I had JRE 8 installed but not JDK 8. 
Fixing the java installation worked.


On Monday, October 2, 2017 at 1:20:55 AM UTC-7, Markus Alexander Kuppe wrote:
On 02.10.2017 00:27, Kapil Agarwal wrote:
> I have been unable to run TLA+ Toolbox 1.5.3 on Mac OS El Capitan 10.11.6 with Java 8 build 1.8.0 installed.
> I have attached the error logs I got on running the toolbox at https://pastebin.com/Kcj26Jf1.
> Any help is appreciated.

Hi Kapil,

something is wrong with your Java 8 installation. If you look at the
third and fourth line of the log file, you will find that the Toolbox
launches with the default Java 6 provided by Apple. For some reason, the
Toolbox launcher does not find Java 8 on your system. You can manually
set the path to Java 8 though, by running the Toolbox with the "-vm"
parameter, e.g.

/Applications/TLA+\ Toolbox.app/Contents/MacOS/toolbox -vm

If the Toolbox launches successfully with the "-vm" parameter, you can
probably fix your system by deinstalling Java 6 (Apple). If it still
doesn't launch, try reinstalling Java 8.